Lazarus 2.0.12 (2021.02.21.)
Letöltés

  • Oldal:
  • 1

TÉMA:

Válasz: Raspberry Lazarus install hiba 2014 okt. 01 16:28 #1401

  • makgab
  • makgab profilkép Témaindító
  • Törzsgárda tag
  • Törzsgárda tag
  • Hozzászólások: 280
  • Köszönetek: 1
Sorry, erre gondoltam. A wiki-n van.
A lényeg, hogy elérhetők az említett csomagok, csak függőségi problémái vannak. :(

Válasz: Raspberry Lazarus install hiba 2014 okt. 01 16:02 #1400

  • Gábor
  • Gábor profilkép
  • Adminisztrátor
  • Adminisztrátor
  • Hozzászólások: 463
  • Köszönetek: 76
Nem a FreePascal írja hivatalosan, hanem a wiki-n van egy cikk, amit a témában többé-kevésbé jártas személyek (nem feltétlenül a Lazarus fejlesztői) írtak és több alkalommal szerkesztettek az idő folyamán. Ez a cikk arról szól, hogy elméletileg hogyan működne a dolog, de amint te is tapasztaltad nálad mégsem működik.
Próbálgathatod az apt-get parancsot a világ végéig, de ha a szükséges csomagok nincsenek a disztribúciód adott változatához tartozó tárban (ez esetben ez elég valószínűnek tűnik) akkor nem fog sikerülni. Persze én is tévedhetek.

Keresd az elérhető csomagok listájában az fpc és a lazarus neveket! Így megbizonyosodhatsz róla, hogy elérhetőek-e és ha igen akkor melyik változat:
apt-cache pkgnames|grep fpc
apt-cache pkgnames|grep lazarus
Hogyan kérdezzünk okosan? / Mit kell tennünk kérdezés előtt? -- FPC 3.3.1 -- Lazarus 2.1.0 -- GNU/Linux 5.4.0 x86_64

Válasz: Raspberry Lazarus install hiba 2014 okt. 01 14:23 #1399

  • makgab
  • makgab profilkép Témaindító
  • Törzsgárda tag
  • Törzsgárda tag
  • Hozzászólások: 280
  • Köszönetek: 1
Pedig a témaindítóban ott a link. Mármint a freepascal hivatalosan is írja: wiki.freepascal.org/Lazarus_on_Raspberry_Pi

"In the Raspbian OS it is easy to install Lazarus and Free Pascal. In order to do this simply open a terminal window and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fpc
sudo apt-get install lazarus"

--
G.

Válasz: Raspberry Lazarus install hiba 2014 okt. 01 06:44 #1398

  • Gábor
  • Gábor profilkép
  • Adminisztrátor
  • Adminisztrátor
  • Hozzászólások: 463
  • Köszönetek: 76
Az üzenet szerint az fpc kötve van az fpc-2.6.0 csomaghoz, amely függőséget azonban nem lehet kielégíteni, mert valószínűleg nincs a csomagtárban.

Próbáld meg kézzel telepíteni az FPC-t! ( ftp://ftp.freepascal.org/pub/fpc/dist/ )
A futtatható Lazarus-t pedig minden bizonnyal forráskódból kell majd létrehozni (kell hozzá az FPC fórráskódja is). Nem tudok róla, hogy létezne a fejlesztők által ARM architektúrára előre elkészített bináris kiadás. ( ftp://ftp.freepascal.org/pub/lazarus/releases/ )
Hogyan kérdezzünk okosan? / Mit kell tennünk kérdezés előtt? -- FPC 3.3.1 -- Lazarus 2.1.0 -- GNU/Linux 5.4.0 x86_64

Raspberry Lazarus install hiba 2014 szept. 30 15:12 #1397

  • makgab
  • makgab profilkép Témaindító
  • Törzsgárda tag
  • Törzsgárda tag
  • Hozzászólások: 280
  • Köszönetek: 1
Üdv!

Megpróbáltam feltenni az fpc , lazarus csomagot a raspbian-ra.
Qemu-ban és egy RPi eszközön is ugyanez a gond:

apt-get update
apt-get upgrade
apt-get install fpc
apt-get install lazarus
...

Dependecy problémát jelez, legfrissebb raspbian. Mi lehet a gond ( lsd. kép )?

Érdekes, hogy Pidora (Fedora Remix 20) esetén is dependecy problémája van. :o


--
G.

  • Oldal:
  • 1